AFX is unresponsive and one or more AFX Connectors are in a Not Deployed state in RSA Identity Governance & Lifecycle
Originally Published: 2019-05-10
Article Number
Applies To
RSA Version/Condition: 7.1.0, 7.1.1, 7.2.0
Issue
Most AFX connectors (AFX > Connectors) show as Running but one or more connectors have a status of Not Deployed (Missing required settings). The current version of the AFX templates have been imported.
The aveksaServer.log file ($AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log) shows the following INFO level log messages over and over again with events occurring every few minutes:
05/09/2019 22:42:06.764 INFO (default task-368) [com.aveksa.afx.server.service.handler.AFXPrimaryRequestHandler] Sending connector Test1 to AFX to be deployed (database revision 3, database create date Tue Feb 26 13:04:39 CST 2019, current AFX revision null, current AFX create date null) 05/09/2019 22:42:06.764 INFO (default task-368) [com.aveksa.afx.server.service.handler.AFXPrimaryRequestHandler] Loading 1 connector(s) to deploy 05/09/2019 22:42:07.500 INFO (default task-368) [com.aveksa.afx.server.service.handler.AFXPrimaryRequestHandler] Loaded 1 connector(s) to deploy 05/09/2019 22:42:07.501 INFO (default task-368) [com.aveksa.afx.server.service.handler.AFXPrimaryRequestHandler] Loading transport(s) for the 1 connector(s) to deploy 05/09/2019 22:42:07.517 INFO (default task-368) [com.aveksa.afx.server.service.handler.AFXPrimaryRequestHandler] Loaded 1 transport(s) 05/09/2019 22:42:07.517 INFO (default task-368) [com.aveksa.afx.server.service.handler.AFXPrimaryRequestHandler] Loading files for the 1 transport(s) and 1 connector(s) to deploy 05/09/2019 22:42:07.518 INFO (default task-368) [com.aveksa.afx.server.service.handler.AFXPrimaryRequestHandler] Loaded 11 file(s)
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform. The aveksaServer.log may also be downloaded from the RSA Identity Governance & Lifecycle user interface (Admin > System > Server Nodes tab > under Logs.)
Cause
A connector cannot be deployed if any of the required fields in the connector are missing. This may occur if something interrupts the deployment or saving of the details for a connector. The connector is left in an indeterminate state that prevents it from being deployed correctly. The failing redeployment of the connector over and over again may cause the AFX server to become unresponsive.
Resolution
- Edit the connectors listed in the INFO level log message and attempt to supply the missing information that is preventing them from being deployed.
- Alternatively delete the problem connector(s).
- Recreate the connector if it is still needed.
- Restart AFX after these steps have been completed. Log in as the afx user:
afx stop afx start
Related Articles
When approval activities are grouped by category, they auto-complete when one of the items is rejected in RSA Identity Gov… 95Number of Views Decision node in RSA Identity Governance & Lifecycle ignores "Contains at least one violation" 40Number of Views Limiting users to one token per user ID in RSA Authentication Manager 8.x 133Number of Views How to install one RSA SecurID software token on multiple devices 629Number of Views Migrating an RSA Authentication Manager deployment from one environment to another 455Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device AFX Server stuck in 'Not running' State, with error 'timed out waiting for AFX applications to start' RSA Authentication Manager Upgrade Process RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide How to install Access Fulfillment Express (AFX) for use with RSA Identity Governance & Lifecycle
Don't see what you're looking for?