Active Directory Account Data Collectors are failing in pre-processing in RSA Identity Governance & Lifecycle
2 years ago
Originally Published: 2017-08-01
Article Number
000045610
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.0.1, 7.0.2
 
Issue
Active Directory Account Data Collectors are failing in preprocessing in RSA Identity Governance & Lifecycle with the following error message in the aveksaServer.log:
 
01/05/2017 07:52:15.266 ERROR (Exec Task Consumer#0) [com.aveksa.server.xfw.TaskExecutor] Failed method=Execute ExecutionTask[TaskID=159 RunID=71 Source=5 Type=DataObjectProcessing Status=InProgress] 
com.aveksa.server.xfw.ExecutionException: com.aveksa.server.collector.DataProcessorException: com.aveksa.server.db.PersistenceException: java.sql.SQLDataException: ORA-01861: literal does not match format string 
ORA-06512: at "AVUSER.ADC_NORMALIZE", line 148 
ORA-06512: at "AVUSER.ADC_NORMALIZE", line 1447 
ORA-06512: at "AVUSER.ADC_DATA_COLLECTOR", line 218 
ORA-06512: at "AVUSER.ADC_DATA_COLLECTOR", line 466 
ORA-06512: at line 1
Cause
This error usually indicates that we are trying to collect something into a Date Field, but it is exceeding the Oracle's Max value. 
Resolution
This issue is fixed in 7.0.1 P03, 7.0.2 P01 and above.