An RSA Identity Management and Governance request form warns that a required field is not provided
Originally Published: 2017-03-03
Article Number
Applies To
RSA Product/Service Type: All
RSA Version/Condition: 6.9.1
Platform: Linux
Issue
Required field account is not provided.
Cause
There are two possible reasons that the data could be missing:
- There is a field on the request form for the required data, and it has not been completed.
- There is no field on the request form for the required data. RSA Identity Management and Governance expects the required data to be in the database, but it is not there.
Resolution
- Check the form to see if there is a field where the required data should be entered. Enter the data if there is such a field.
- If there is no field on the form for the required data, see if the data is missing from the database, and if so why. To search for the data you require:
- Use the RSA Identity Management and Governance's User Interface's reports and menus, such as the Users menu, to determine if the data is present in RSA IMG.
- Use an SQL query to search a relevant database view for the data. Views are documented in the RSA Identity Management & Governance 6.9.1 Public Database Schema Reference.
- To find why expected data appears to be missing from the database, the following can be checked:
- Collector. Check that the relevant collector is configured correctly and that it is running regularly without errors. If necessary, run the collector to get the latest data.
- Business/Data source. Check the organization's data to confirm if the missing data is present there. For example, check Active Directory to ensure accounts are correctly associated with the user there.
- Form. Check the form and workflow design to confirm if the missing data should truly be mandatory. Are there concurrent/pending or recently completed workflows that may be causing conflicts?
- Has there been any recent data migrations and if so, did the data migrate correctly?
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