Approval activity throws a Request Could Not Be Handled error in RSA Identity Governance & Lifecycle
5 months ago
Originally Published: 2024-10-02
Article Number
000072923
Applies To
  • SecurID Governance Lifecycle 7.5.2

Issue

Upon navigating to Requests > Activities > Activities by Assignee, an Approval activity is stuck in the Available state with the Perform button active. There are no linked Change Requests to that Approval activity. The area highlighted in yellow (next to Supervisor Approval) should have a hyperlink that displays a pop-up with the related Change Request but in this case, there were none. Clicking on the Perform throws the below "Request Could Not Be Handled" error window: 



Cause

This is due to the deletion of the corresponding Change Request.

Workaround

Contact Technical Support for follow up guidance clean up the Approval activity from the Database. The below workaround is to find the Change Request for the Approval activity, and cancel the corresponding Change Request. 

  1. Obtain the OID of the activity by clicking Perform. The OID is in the URL.
  2. Check the Change Request ID related to this activity by running the following queries:
    select * from WP_ACTI where acti_id=<OID>
    
    select * from wp_proci where proci_id=<proci_id from the first query>
  3. From the results of the above query:
    1. Find the column named CR_ID.
    2. Check if there is a Change Request for this ID.
      select * from t_av_change_requests where id=<CR_ID from the previous query>
  4. If there is a CR found:
    1. Go to any Change Request page and replace the OID in the URL with the CR ID found found from the above query, press Enter.
    2. This will take you to the Change Request's page, cancel the request.