Email triggered for 'Please reset your current password' after a password reset
2 years ago
Originally Published: 2019-01-03
Article Number
000042013
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle 7.0.2
Issue
User successfully performs 'Forgot Password' flow to reset a password. However after sometime an email is triggered from IGL to user:
Under Email -> Log tab:
Event Type: PasswordResetEvent
Subject: “Please reset your current password”
 
Email body triggered to user:
 
Hello <User>,
Your password on ACTIVE DIRECTORY has been reset by someone else.
Please change your password as soon as possible to avoid compromise of your account.
These reminders will be sent to you periodically until you change your password.
Thank you.

 
 
Cause
This is due to a known bug in 7.0.2.
Password reset email event should be PasswordAvailableExtEvent instead of PasswordResetEvent.
 
Resolution
Issue is fixed as part of 7.0.2 P1.