Error on migrating to 7.1.1: IO Error: Connection reset by peer
Originally Published: 2019-05-18
Article Number
Applies To
RSA Product/Service Type: Enterprise Software
RSA Version/Condition: 7.1.0
Cause
Automatic report capturing is a new feature in oracle 12c.
As part of this feature, some monitoring SQLs are executed by MMON_SLAVE to identify the resource-intensive SQLs queries. And this monitoring SQLs while executing sometimes fail and this type of error will be logged in the alert log.
Oracle already acknowledged this bug.
However, to fix this the workaround is to set parameter And this doesn’t need database bounce.
After setting this parameter, this type of error will be suppressed. Please refer to a workaround section below.
Resolution
As per our webex over the week end, aveksaServer.log indicated the connection errors as below:
Caused by: java.io.IOException: Connection reset by peer
at sun.nio.ch.FileDispatcherImpl.read0(Native Method)
.......................
at oracle.jdbc.driver.T4CStatement.executeForRows(T4CStatement.java:896)
... 16 more
SQL error encountered while reverting the transaction of the failed script
java.sql.SQLException: IJ031040: Connection is not associated with a managed connection: org.jboss.jca.adapters.jdbc.jdk7.WrappedConnectionJDK7@2f6c6960
at org.jboss.jca.adapters.jdbc.WrappedConnection.lock(WrappedConnection.java:164)
at org.jboss.jca.adapters.jdbc.WrappedConnection.rollback(WrappedConnection.java:854)
During webex we confirmed that the the connection to the SQLPlus worked fine. So we triggered the migration again and this time it completed successfully and you were able to log-in to IG&L 7.1.1 successfully.
You also mentioned that the you have applied all Oracle Patches up-to-date with quarterly patches.
==>
This error "Connection is not associated with a managed connection: org.jboss.jca.adapters.jdbc.jdk7.WrappedConnectionJDK7@2f6c6960 " means that your code is using a connection that is no longer valid (ie. closed/destroyed connection due to a connection error or invalid connection cache by the application where the cached connection is closed by some other piece of code upstream). In your case the connection id from the pool is @2f6c6960.
So you can refer to this in the TRACE level logging to see if you can find out why the connection was closed (due to some error like DB killed connection or network issues or application code handling the connection incorrectly).
Although you have applied latest April PSU from Oracle, please note that as mentioned in KB-000036810
- This error "Patching has failed. Connection is not associated with a managed connection.org.jboss.jca.adapters.jdbc.jdk7.WrappedConnectionJDK7@738e9520" is caused by Oracle bug 24530463 - FA: GATHER STATS ON DOO_HEADERS_ALL FAILS W/ ORA-600 [QKAFFSINDEX3], which prevents the database statistics from completing correctly.
- See Oracle knowledge article 2395827.1 - Exadata Database is Reporting ORA-00600:[qkaffsindex3] for more information.
- Issue is resolved in Oracle patch: 24530463 : Description FA: GATHER STATS ON DOO_HEADERS_ALL FAILS W/ ORA-600 [QKAFFSINDEX3]
Workaround
The sid and serial number can be obtained from ASH report. Document 2031605.1 Adaptive Query Optimization
SQL> alter system set "_report_capture_cycle_time"=0; /* Default is 60 seconds */
NOTE: _report_capture_cycle_time=0 /* This is system modifiable with immediate */
TIP: There are some known bugs for the problem which are fixed in latest PSU of 12.1.0.2. Hence, it is strongly recommended to apply the latest PSU for 12.1.0.2.
Document 1924126.1 12.1.0.2 Patch Set Updates – List of Fixes in each PSU
REFERENCES
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