Error requesting CT-KIP token for RSA SecurID Software Token for Microsoft Windows through RSA SecurID Access Prime Self-Service Console
a year ago
Originally Published: 2020-05-21
Article Number
000044629
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: RSA SecurID Access Prime
Issue

The following error is displayed in the ../primekit/logs/ssp/ssp_daily.log when a user requests an RSA SecurID Software Token for Microsoft Windows through the RSA SecurID Access Prime Self-Service Console:

2020-04-22T14:52:49,922-0400,com.rsa.pso.selfservice.web.SSPHomeActionBean,51,INFO ,Request for new Token {"TT":"software","DT":"Desktop PC#5.x","SHIP":"undefined","PIN":"******","QRCode":true,"emaildId":"null","distpwd"******""}

2020-04-22T14:53:01,597-0400,com.rsa.pso.selfservice.web.SSPHomeActionBean,51,INFO ,requestNewSoftwareToken() devicetype Desktop PC#5.x
2020-04-22T14:53:01,598-0400,com.rsa.pso.selfservice.web.SSPHomeActionBean,51,INFO ,DistributionType for Desktop PC#5.x: CTKIP_QRENABLED
.
.
2020-04-22T14:53:07,923-0400,com.rsa.pso.services.NotificationServiceHelper,51,INFO ,FAILURE_LOG[$Thread: 25
com.rsa.pso.services.ServiceException: Device not available
STACK_TRACE[$com.rsa.pso.services.ServiceException: Device not available
com.rsa.pso.services.NotificationServiceHelper.distributeTokenCTKIPQRCode(Unknown Source)

 

Cause

The /opt/rsa/primekit/configs/ssp/config/device.xml file has the Desktop PC property name pointing to Desktop PC 5.x, but the RSA Authentication Manager server has only Desktop PC 4.x:

 

<bean class="com.rsa.pso.selfservice.securid.MobileDevice" parent="defaultMobileDevice">
<property name="deviceFamilyName" value="Desktop PC" />
<property name="versionNumber" value="5.x" />
<property name="deviceManager" ref="blankDeviceManagerBean" />
<property name="distributionType" ref="CTKIP_DISPLAY" />
</bean>

 

Resolution

To correct the error,

  1. Edit the /opt/rsa/primekit/configs/ssp/config/device.xml file.
  2. Change the  versionNumber value to 4.x. For instance:

<property name="versionNumber" value="4.x" />

  1. Restart the SSP Service.

cd /opt/rsa/primekit/scripts
./ ssp_shutdown.sh
,/ssp_startup.s
h

 

See Notes for alternate solution for similar symptoms

Notes

Same symptoms seen on another SSP.

But this was due to lack of free space on SSP server

Because log rotation was not setup, so after many months, disk filled with logs