Help Desk Admin Portal random timeouts during admin login or when searching for a user in RSA Authentication Manager 8.1
Originally Published: 2015-12-01
Article Number
Applies To
RSA Product/Service Type: Authentication Manager Prime, Help Desk Admin Portal (HDAP)
RSA Version/Condition: 8.1.0
Issue
An Unexpected Error occurred in the server.
When looking up a user the error message below would be reported.
java.lang.exception : ERROR (lookupUser): Unable to find user XXXX
The first scenario would be help desk admin portal admin users attempting to login to the portal page as an admin who is an AD user, not a local DB user in AM 8.1. The login times out after 30 or so seconds and you get a generic error below.
The second scenario would be the admin is able to login, but when they try to lookup a user that is a member of AD/Identity source it fails with an error similar to the example below.
com.rsa.ucm.AuthManager.AmisCommandTargetException : Current user context not set up. call beginUserSession.
Cause
To confirm this is related to the same issue, edit the am8-config.xml file, search for am8BindStrategy it will be set to single then search for multi-tanant it will be set to true next to enabled.
The am8-config.xml can be found under C:\RSA\AMIS\am8-config.xml under windows and /opt/RSA/AMIS/am8-config.xml under linux
Resolution
- Edit C:\RSA\AMIS\am8-config.xml under windows or /opt/RSA/AMIS/am8-config.xml under linux.
- Search for the following line and change the value from single to threaded.
<am8BindStrategy>single</am8BindStrategy>
- Once the value has been changed, save changes, then restart amis tomcat services for AMIS and HDAP.
Refer to the article How to stop and start Authentication Manager Prime Tomcat services for information on how to stop and start Authentication Manager Prime services.
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