Help Desk Admin Portal random timeouts during admin login or when searching for a user in RSA Authentication Manager 8.1
a month ago
Originally Published: 2015-12-01
Article Number
000042196
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager Prime, Help Desk Admin Portal (HDAP)
RSA Version/Condition: 8.1.0
Issue
Help Desk Admin Portal experiences random timeouts during admin login or when searching for a user, displaying the error below.
An Unexpected Error occurred in the server.
User-added image

When looking up a user the error message below would be reported.
java.lang.exception : ERROR (lookupUser): Unable to find user XXXX

The first scenario would be help desk admin portal admin users attempting to login to the portal page as an admin who is an AD user, not a local DB user in AM 8.1. The login times out after 30 or so seconds and you get a generic error below.

The second scenario would be the admin is able to login, but when they try to lookup a user that is a member of AD/Identity source it fails with an error similar to the example below.
com.rsa.ucm.AuthManager.AmisCommandTargetException : Current user context not set up. call beginUserSession.
User-added image
Cause
This can be caused if the customer is using Multi-Tenant mode with help desk admin portal and they have set the value am8BindStrategy to single in the am8-config.xml file. 

To confirm this is related to the same issue, edit the am8-config.xml file, search for am8BindStrategy it will be set to single then search for multi-tanant it will be set to true next to enabled. 

The am8-config.xml can be found under C:\RSA\AMIS\am8-config.xml under windows and /opt/RSA/AMIS/am8-config.xml under linux
Resolution
To resolve this issue do the following:
  1. Edit  C:\RSA\AMIS\am8-config.xml under windows or /opt/RSA/AMIS/am8-config.xml under linux.
  2. Search for the following line and change the value from single to threaded.
    <am8BindStrategy>single</am8BindStrategy>
  3. Once the value has been changed, save changes, then restart amis tomcat services for AMIS and HDAP.

Refer to the article How to stop and start Authentication Manager Prime Tomcat services  for information on how to stop and start Authentication Manager Prime services.