Invalid date format error in RSA Identity Governance & Lifecycle Salesforce collections
2 years ago
Originally Published: 2018-01-08
Article Number
000040618
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.0.2
 
Issue
When using a Salesforce Collector and collecting the LastLoginDate attribute, the attribute does not appear in the UI and the following admin error is seen:
 
Data Source: Salesforce ADC(ID=89): Found 1390 errors: Data Format Error in Account Record. Record ID=abc@rsa.com, Attribute=LAST_LOGIN_DATE, Value="2017-12-15T21:25:46.000+0000", Expected Data Type=DATE Problem: Invalid Date Format or Date Range Acceptable Date Range From: 01-Jan-0001 00:00:00 To: 31-Dec-9999 23:59:59
 
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Cause
The LastloginDate attribute was collected successfully from Salesforce, but it was not in date format and thus, was not shown on the UI after collection. 

 
Resolution
This issue has been reported in ACM-79634 and is fixed in 7.1.0 which is expected to be released in February 2018.