ORA-31061 or ORA-19202 generating ASR report or Log Artifacts in RSA Identity Governance & Lifecycle
Originally Published: 2021-07-19
Article Number
Applies To
RSA Version/Condition: 7.2.0, 7.2.1, 7.5.0
Issue
Generation of Log Artifacts fails in step generate ASR report.
One of the following ERROR messages (ORA-31061 or ORA-19202) is logged in aveksaServer.log file:
01/07/2021 20:16:47.143 ERROR (SystemReportGenerator) [SystemErr] Caused by: com.aveksa.server.db.PersistenceException: java.sql.SQLException: ORA-31061: XDB error: special char to escaped char conversion failed. ORA-06512: at "AVUSER.SYSTEM_REPORT", line 287 ORA-06512: at line 1
06/03/2021 11:39:54.914 ERROR (SystemReportGenerator) [SystemErr] Caused by: com.aveksa.server.db.PersistenceException: java.sql.SQLException: ORA-19202: Error occurred in XML processing ORA-01489: result of string concatenation is too long ORA-06512: at "AVUSER.SYSTEM_REPORT", line 287 ORA-06512: at "SYS.DBMS_XMLGEN", line 237 ORA-06512: at "SYS.DBMS_XMLGEN", line 271 ORA-06512: at "AVUSER.SRXML", line 76 ORA-06512: at "AVUSER.SRXML", line 104 ORA-06512: at "AVUSER.SRSECTION_OBJECTS", line 23 ORA-06512: at "AVUSER.SRSECTION_OBJECTS", line 23 ORA-06512: at "AVUSER.SYSTEM_REPORT", line 200 ORA-06512: at "AVUSER.SYSTEM_REPORT", line 259 ORA-06512: at line 1
Cause
- RSA Identity Governance & Lifecycle 7.2.0 P05
- RSA Identity Governance & Lifecycle 7.2.1 P01
- RSA Identity Governance & Lifecycle 7.5.0
This issue occurs for some customers who have legacy workflow data for the looping workflow section of the report that exceeds 4000 characters.
Resolution
- RSA Identity Governance & Lifecycle 7.2.0 (please upgrade to 7.2.1)
- RSA Identity Governance & Lifecycle 7.2.1 P06
- RSA Identity Governance & Lifecycle 7.5.0 P03
Workaround
Notes
Related Articles
Log Artifacts generation fails due to ORA-31061 error in ASR report generation in RSA Identity Governance & Lifecycle 117Number of Views Artifacts to gather in RSA Identity Governance & Lifecycle 3.95KNumber of Views ASR fails to generate with an 'ORA-31011: XML parsing failed ORA-06512: at "AVUSER.SYSTEM_REPORT", line 245' error in RSA … 224Number of Views How to create an Aveksa Statistics Report (ASR) from the linux command line prompt using SQL in RSA Identity Governance & … 451Number of Views ASR fails to generate with an 'ORA-01422: exact fetch returns more than requested number of rows' error in RSA Identity Go… 65Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA SecurID software token .sdtid file fails to import into RSA SecurID Software Token 5.0 for Windows RSA Authentication Manager 8.9 Patches and Hotfixes Readme Download RSA SecurID Access Cloud User Event audit logs using Cloud Administration REST API CLU RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?