Patch/upgrade fails with 'java: No such file or directory' error in RSA Identity Governance & Lifecycle
4 years ago
Originally Published: 2020-03-03
Article Number
000042713
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.0.x, 7.1.x, 7.2.0
 
Issue
When patching or upgrading RSA Identity Governance & Lifecycle, the process fails and the following error is generated in the patch.log file (/home/oracle/{patch}/logs/{patch-date}.log):
 
Preparing the ear file for deployment at Tue Dec 17 19:46:52 EST 2019
 – Expanding the CURRENTLY deployed ear to filesystem for further checks to apply patch.
 ./customizeACM.sh: line 6: /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/bin/java: 
No such file or directory
 An error occured in the customizeACM command : error code 127
 Step failed! See /home/oracle/Aveksa_7.1.1_P03/logs/7.1.1_P03_2019-12-17-1946.log 
for more information.
Cause
This is a known issue reported in engineering ticket ACM-103057.

This issue may occur if the Java update is applied before the patch or upgrade is performed.  The patch fails because the JAVA_HOME variable is not updated immediately after the Java update. 
 
Resolution
This issue is resolved in the following RSA Identity Governance & Lifecycle patch levels: 
  • RSA Identity Governance & Lifecycle 7.1.1 P06
  • RSA Identity Governance & Lifecycle 7.2.0 P01

 
Workaround
After the failure, the JAVA_HOME variable will have been updated so rerunning the patch/upgrade again will resolve this issue.
  1. Log out of the application server (log out of root)
  2. Log in again as the root user.
  3. Run the patch or upgrade again.