RSA Product Set: ID Plus
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: AM 8.7 SP1, 8.7 SP2, 8.8
Fixed in AM 8.8 patch 2, but problem observed again in AM 8.9 and AM 8.9 Patch 1
RSA Authentication Manager server fails to boot Entering Emergency Mode (Dracut Emergency shell) - with a warning /dev/sda3 does not exist
/dev/sda3 is defined as root. Sometime restart fails with error "/dev/sda3 does not exist".
This is a recognized behavior/bug in SUSE, where the disk partition label changes dynamically. At times, it does not match the label used during the Linux installation, which can lead to restart failures.
https://www.suse.com/support/kb/doc/?id=000018449
Reboot the virtual machine. This restart should automatically fix the issue.
It is observed that when rebooting the Virtual Machine from vSphere, you may bypass Emergency Mode; however, you will be unable to interact with anything while the start job for /dev/sda3 is running indefinitely.
In that case - Turn off the virtual machine via VMware vSphere or Hyper-V, and then restart it.
Note: The anticipated release of RSA Authentication Manager 8.8 P2 is provisionally set to incorporate the SUSE fix.
If you find that you are frequently affected - Due to your scheduled maintenance activities necessitating regular server reboots - RSA support uses a workaround suggested by SUSE
https://www.suse.com/releasenotes/x86_64/SUSE-SLES/15-SP2/index.html#jsc-SLE-11117
The RCA and workaround, are provided by SUSE and not by RSA for implementation.
Below are steps to apply the changes in VM :
1. Find the storage drive name
lspci -nnk | grep -A3 -i "storage|sata|nvme"
2. Edit grub file
vi /etc/default/grub
3. Look for the line:
GRUB_CMDLINE_LINUX_DEFAULT=
4. Append the kernel parameter: scsi_mod.disable_async_probing=mptspi
Keep the quotes and make sure there are no line breaks.
5. Save the file
6. update the Gurb Config
grub2-mkconfig -o /boot/grub2/grub.cfg
7. Reboot the VM
8. Verify the applied changes
cat /proc/cmdline
Related Articles
Memory/battery problems were detected error and boot process is stuck during boot of Dell-based or Intel-based RSA SecurID… 47Number of Views Emergency Access for Cloud Access Service Users 130Number of Views RSA SecurID Appliance hangs when booting on NTP service for RSA Authentication Manager 8.1 339Number of Views RSA Authentication Manager virtual machine failed to boot server for JVM memory error 1.3KNumber of Views RSA Certificate Manager's GUI Reporting Tool displays a different user-count value than the Event Viewer (or Syslog) 68Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device How to implement SAML SSO Authentication with Microsoft Azure Active Directory and RSA Identity Governance & Lifecycle "No decryption codes were found in the zip file" error when decrypting RSA SecurID tokens How to download full kits, service packs, and patches from RSA Link for RSA Identity Governance & Lifecycle RSA Governance & Lifecycle 8.0.0 Upgrade and Migration Guide