RSA Via Lifecycle and Governance access control setting for web services gets reset to default on server restart
Originally Published: 2016-02-02
Article Number
Applies To
RSA Product/Service Type: All
RSA Version/Condition: 5.x,6.5.1,6.5.2,6.8.1,6.9
Issue
The web services configuration feature in the RSA Via L&G user interface enables you to enable and disable web services and specify the clients allowed to access web services. It also provides comprehensive information on commands, command options, and command examples.
You can manage web services by selecting Admin >Webservices as follows:
1.Enable and disable web services.
2.Control which client IP addresses can issue web services commands.
3.Specify an import directory for import commands.
4. Customize web services commands: enable or disable and change the request type (GET or POST).
The list of IPs allowed to invoke web services field on the Web Services main page lists any IP addresses allowed to issue web services commands. An empty list indicates that all clients can access web services.
By default only local host IP address 127.0.0.1 can issue web services commands if web services is enabled. If you have enable "IPs allowed to invoke web services" field to empty to allow all connections an now if you restart Via L&G server ,this setting resets to default.
Cause
Steps to reproduce:
1. Go to Admin > Web Services > Edit
2. Set the block for the "IPs allowed to send invoke web services " to Empty to allow all connections
3. Restart the server.
4. Now when you go an check the webservices the "IPs allowed to send invoke web services " gets reset to default
Resolution
Related Articles
Customizing the logo and the label of the kiosk for Self-Service Password Reset in RSA Identity Governance and Lifecycle 107Number of Views Enable password reset in RSA Identity Governance & Lifecycle 249Number of Views Reset Forgotten Password for the Cloud Administration Console 145Number of Views Cannot log on to Microsoft Windows 8.1 with RSA Authentication Agent 7.3.x for Windows after Windows update is applied usi… 56Number of Views RSA Card Reset Utility unable to unlock/reset SmartCard PIN 120Number of Views
Trending Articles
RSA Authentication Manager Upgrade Process Download RSA SecurID Access Cloud User Event audit logs using Cloud Administration REST API CLU RSA Authentication Manager Patch Updates How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?