Unable to log into Configuration Manager or roll back after adding password key to schema in RSA Web Threat Detection 6.1
Originally Published: 2017-05-15
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Forensics
RSA Version/Condition: 6.1
Platform: Centos : 6.0
Issue
Cause
- Customer is unable to log into Configuration Manager or Analytics UI. Also, cannot roll back the changes.
- Customer can't login to the UI or Configuration Manager. Authentication failed with the following Message:
"Connection to the database not established "
- When trying to roll back using Safe mode the following message appeared:
Error: [Errno 13] Permission denied: '/var/opt/silvertail/etc/uiserver/uiserver.conf' (IOError)
- I reviewed the logs and verified that AnnoDb did not start.
File ownership under "/etc/init.d/" changed to RSAWTD with permission 777. Therefore file permissions were changed from rsawtd:rsawtd to root:root for file "/var/opt/silvertail/bin/scout-service.sh" and service started up.
- The previous step was applied to the rest of the services to fix the permission issue and be able to start the rest of WTD services.
- After the permissions were corrected, the Customer was able to roll back using Safe Mode. However, message logs reported the following error :
ServerName.DomainName annodb[99701]:MainThread:ERROR:AnnoDb Failed to start.
May 10 23:09:29 ServerName.DomainName annodb[104128]:MainThread:INFO:Silver Tail AnnoDb version 6.1.0.135 May 10 23:09:53 ServerName.DomainName silvercat.py[104205]:MainThread:INFO:Silver Tail SilverCat version 6.1.0.135
May 10 23:09:53 ServerName.DomainName silvercat.py[104205]:MainThread:ERROR:[Errno 1] Operation not permitted: '/var/opt/silvertail/etc/universal_conf.py'#012Traceback (most recent call last):#012 File "/var/opt/silvertail/bin/silvercat.py", line 86, in main#012 silvercat_handler.Serve(conf, SilverCatVarz())#012 File "python/st/icat/silvercat_handler.py", line 6108, in Serve#012 File "python/st/icat/silvercat_handler.py", line 4654, in __init__#012 File "python/st/icat/service.py", line 273, in SetConfigFilePermissions#012OSError: [Errno 1] Operation not permitted: '/var/opt/silvertail/etc/universal_conf.py'
May 10 23:09:29 ServerName.DomainName annodb[104128]:MainThread:INFO:Silver Tail AnnoDb version 6.1.0.135 May 10 23:09:53 ServerName.DomainName silvercat.py[104205]:MainThread:INFO:Silver Tail SilverCat version 6.1.0.135
May 10 23:09:53 ServerName.DomainName silvercat.py[104205]:MainThread:ERROR:[Errno 1] Operation not permitted: '/var/opt/silvertail/etc/universal_conf.py'#012Traceback (most recent call last):#012 File "/var/opt/silvertail/bin/silvercat.py", line 86, in main#012 silvercat_handler.Serve(conf, SilverCatVarz())#012 File "python/st/icat/silvercat_handler.py", line 6108, in Serve#012 File "python/st/icat/silvercat_handler.py", line 4654, in __init__#012 File "python/st/icat/service.py", line 273, in SetConfigFilePermissions#012OSError: [Errno 1] Operation not permitted: '/var/opt/silvertail/etc/universal_conf.py'
- A similar error was seen in JIRA WTD-5067 which concluded that the cause was related to missing dependencies.
Resolution
Enabling Debug Mode on CentOS
- Login to your WTD box via SSH and SU to root.
- Use VI to edit this file /etc/rsyslog.conf.
- Insert the following line.
*.debug /var/log/debug
- Save the file
- Restart the srsyslog service by running the command below:
sudo /sbin/service rsyslog restart
- Stop UI server
/etc/init.d/st-UIServer-0 stop
- start UI server in debug mode
/var/opt/silvertail/bin/uiserver -f /var/opt/silvertail/etc/conf.d/UIServer-0/UIServer-0.conf --loglevel=debug
- leave it running for a 5 minutes and provide /var/log/messages and /var/log/debug files to Customer Support.
Related Articles
Collect Prime logs and Configuration files using the collect script 179Number of Views How to import a Root CA or public key Certificate into an Authentication Manager (or AMIS) java key store .jks with keytool 280Number of Views Maximum number of incorrect login attempts for RSA Authentication Manager Operations Console administrator 195Number of Views RSA Authenticator 6.2 for Windows Quick Start Guides 155Number of Views RSA Authenticator 4.6 for iOS and Android Quick Start Guides 48Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Unable to login to RSA Authentication Manager Security Console as super admin RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory
Don't see what you're looking for?