Error: ' (RSALogger.java:764) - [CSF-InitializationFailed: ] The system has not been initialized.' appears in logs during WebLogic service startup shortly before the application server has completely started
2 years ago
Originally Published: 2003-04-30
Article Number
000062508
Applies To
RSA Mobile 1.0
RSA Mobile 1.5
Microsoft Windows 2000 Professional SP3
Issue
Error: "2003-05-01 09:42:46,670 FATAL [ExecuteThread: '25' for queue: 'default'] log4j.RSALogger (RSALogger.java:764) - [CSF-InitializationFailed: ] The system has not been initialized." appears in logs during WebLogic service startup shortly before the application server has completely started
Cause
The root cause of this error message is that the configured SMS service (in this example "smpp") is not online or reachable, and it appears during RSA Mobile service startup (e.g. from running "startmanagedauthserver.cmd" at the command line). Although the application server carries on its startup routine, the actual RSA Mobile service will not be available.
Resolution
The goal of RSA Mobile is to deliver one time PASSCODE via SMS; if the SMS service is unavailable, RSA Mobile will be unable to carry out its role. If messages like this are seen during the startup of RSA Mobile, contact your SMS service provider to identify why the service is not available.

Details of the connection parameters are stored in the SMS-smpp.properties file and may be examined or modified using a text editor. If changes are made while RSA Mobile is running, the service must be stopped and restarted to pick up the changes.
Workaround
The command 'configtool CONFIGSMS smpp' has been run to configure the smpp service
The smpp service has been configured correctly in the SMS-smpp.properties file