KCA has problems publishing to Microsoft Exchange Server
Originally Published: 2004-07-15
Last Modified: 2023-10-06
Article Number
Applies To
Microsoft Windows 2000 Server SP4
Microsoft Exchange Server 2000
Microsoft Windows XP
Microsoft Outlook 2000
Microsoft Active Directory
Issue
Enable KCA Publishing to Exchange Server/GAL
If user is located in cn=users, dc=na, dc=acme, dc=com, certificate does get published to user's GAL. If the user is located anywhere else such as cn=users, ou=pki, dc=na, dc=acme, dc=com it fails to post.
Cause
User not located in standard Microsoft Active Directory location of cn=users, dc=na, dc=acme, dc=com
Resolution
The ActiveX component (kcaoutlook.dll) responsible for publishing the Certificate to the Global Address List (GAL) does not have administrative rights that enables it to search for user locations in the Active Directory through the LDAP interface. Therefore, it assumes the publishing location is always CN=<user name>, CN=Users, <base dn>, where 'base dn' is created from the FQDN of the exchange server (e.g. if FQDN is server.company.com, base dn is DC=server,DC=company,DC=com).
Related Articles
Memory/battery problems were detected error and boot process is stuck during boot of Dell-based or Intel-based RSA SecurID… 47Number of Views Generic REST Collector problems with Authentication (OAuth2, Bearer Token or Basic Authentication) in RSA Governance & Lif… 363Number of Views General problems with Scheduler in RSA Governance & Lifecycle 120Number of Views Problems with Aveksa Application Roles and Entitlements managed in the RSA Identity Governance & Lifecycle Aveksa Applicat… 130Number of Views RSA Identity Governance and Lifecycle installation fails with the error: Problem running roothas.pl 299Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA Authentication Manager Patch Updates Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update How to Forward RSA Authentication Manager 8.4 or Later Logs to Multiple Syslog Servers Using rsyslog
Don't see what you're looking for?