Authentication Manager 7.x stops authenticating and hanging - unable open any tab in Security and Operations Console after running live backups or antivirus scan
2 years ago
Originally Published: 2008-09-16
Article Number
000045319
Applies To
RSA Authentication Manager 7.1
Issue

Authentication Manager 7.x stops authenticating and hanging - unable open any tab in Security and Operations onsole

 

Problem is intermittent and seems to randomly occur from 4 hour to two-day intervals.

 

Oracle trace logs are showing this error:

error 221 detected in background process
OPIRIP: Uncaught error 447. Error stack:
ORA-00447: fatal error in background process
ORA-00221: error on write to control file

 

Another symtom is you may see this error in the alert_XXXXXXX.log  ( in ..\RSA Authentication Manager\db\admin\XXXXXX\bdump) 

KCF: write/open error block=0x2fc online=1
     file=5 C:\PROGRA~1\RSASEC~1\RSAAUT~1\DB\ORADATA\KLKDSKEA\RSA_DATA.DAT
     error=27072 txt: 'OSD-04008: WriteFile() failure, unable to write to file
O/S-Error: (OS 33) The process cannot access the file because another process has locked a portion of the file.'

 or:

LGWR: terminating instance due to error 340

Cause

Site is either performing live backups of the Oracle database using a third party backup tool or running an Antivirus scan of the Oracle files. In either event, an Oracle control file is locked and cannot being written to.

Resolution
RSA only supports Oracle backup procedures documented in the 7.1 Administration Guide.