java.lang.StackOverflowerror when viewing the Request Activities page in RSA Identity Management and Governance
Originally Published: 2017-01-12
Article Number
Applies To
RSA Version/Condition: 6.9.0
Issue
java.lang.StackOverflowerror
Cause
To verify that this is the cause,
- Run the query below as 'avuser' replacing the AveksaAdmin user with the USER_ID of the affected user.
SELECT Meu.id,Meu.User_Id, Meu.Last_Name, Meu.First_Name, Meu.Email_Address, Sus.* FROM t_system_ui_settings SUS JOIN t_master_enterprise_users MEU ON MEU.ID=SUS.USER_MEUID WHERE MEU.USER_ID = 'AveksaAdmin';
- Look for the SETTING_TYPE 'Table Data', and the value in the SETTING column.
Resolution
- Copy and paste the content of the SETTING column field with SETTING_TYPE 'Table Data' into Notepad++ or another technical editor. You may see, as in this case, over 1200 entries for this entry:
<string>SortDir</string>
<com.aveksa.server.utils.collections.sorting.SortCriteria>
<list>
<com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
<property>WORKITEM_ID</property>
<order>ASC</order>
</com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
<com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
<property>PRIORITY_ORDER</property>
<order>ASC</order>
</com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
<com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
<property>PRIORITY_ORDER</property>
<order>ASC</order>
</com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
<com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
<property>PRIORITY_ORDER</property>
<order>ASC</order>
</com.aveksa.server.utils.collections.sorting.SortCriteria_-SortProperty>
These duplicates might be spread over more than one Property.
- Save the original content to a file.
- Delete the duplicates, being mindful of xml begin and end tags.
- Copy the resulting, much shorter, file back into the SETTING column and save the entry.
- Have the user login and logout and try the Activities tab again. It should now work.
Related Articles
Duplicate a Report 6Number of Views Run a Report Job 20Number of Views Run Reports 148Number of Views Sample Reports 31Number of Views Reports 56Number of Views
Trending Articles
RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide RSA Authentication Manager 8.9 Release Notes (January 2026) RSA Release Notes for RSA Authentication Manager 8.8 RSA announces End of Life EOL dates for RSA MyAccessLive Service RSA Authentication Manager 8.9 Administrator's Guide
Don't see what you're looking for?