This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Accept
Reject
  • RSA.com
  • Home
  • Advisories
    • SecurID
    • SecurID Governance & Lifecycle
  • Documentation
    • SecurID
      • Authentication Agents
        • API / SDK
        • Apache Web Server
        • Citrix StoreFront
        • IIS Web Server
        • MFA Agent for macOS
        • MFA Agent for Windows
        • Microsoft AD FS
        • Microsoft Windows
        • PAM
      • Authentication Engine
      • Authentication Manager
      • Cloud Authentication Service
      • Hardware Appliance
        Component Updates
      • Hardware Tokens
      • Integrations
      • SecurID App
      • SecurID Authenticator for macOS
      • SecurID SDK
      • Software Tokens
        • Android
        • iOS
        • macOS
        • Token Converter
        • Windows
    • SecurID Governance & Lifecycle
    • Technology Partners
  • Downloads
    • SecurID
      • Authentication Agents
        • API / SDK
        • Apache Web Server
        • Citrix StoreFront
        • IIS Web Server
        • MFA Agent for macOS
        • MFA Agent for Windows
        • Microsoft AD FS
        • Microsoft Windows
        • PAM
      • Authentication Engine
      • Authentication Manager
      • Cloud Authentication Service
      • Hardware Appliance
        Component Updates
      • Hardware Tokens
      • Integrations
      • SecurID Authenticator for macOS
      • Software Tokens
        • Android
        • iOS
        • macOS
        • Token Converter
        • Windows
    • SecurID Governance & Lifecycle
  • Community
    • SecurID
      • Blog
      • Discussions
      • Events
      • Idea Exchange
      • Knowledge Base
    • SecurID Governance & Lifecycle
      • Blog
      • Discussions
      • Events
      • Idea Exchange
      • Knowledge Base
  • Support
    • Case Portal
      • Create New Case
      • View My Cases
      • View My Team's Cases
    • Community Support
      • Getting Started
      • News & Announcements
      • Ideas & Suggestions
      • Community Support Articles
      • Community Support Forum
    • Product Life Cycle
    • Support Information
    • General Security Advisories
  • Education
    • Blog
    • Browse Courses
      • SecurID
      • SecurID Governance & Lifecycle
    • Certification Program
    • New Product Readiness
    • Student Resources
Sign In Register Now
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
Announcements

SecurID® Knowledge Base

Find answers to your questions and identify resolutions for known issues with knowledge base articles written by SecurID experts.
  • SecurID Community
  • :
  • Products
  • :
  • SecurID
  • :
  • Knowledge Base
  • :
  • RSA Authentication Agent 7.x and 8.x for Web for IIS WebID (IISWebAgentIF.dll) display a blank scree...
  • Options
    • Subscribe to RSS Feed
    • Bookmark
    • Subscribe
    • Email to a Friend
    • Printer Friendly Page
    • Report Inappropriate Content

RSA Authentication Agent 7.x and 8.x for Web for IIS WebID (IISWebAgentIF.dll) display a blank screen redirect

Article Number

000033710

Applies To

RSA Product Set: SecurID
RSA Product/Service Type: Authentication Agent for Web for IIS
RSA Version/Condition: 7.x, 8.x
O/S Version: Microsoft Server 2008, 2008 R2, 2012, 2012 R2
 

Issue

When clicking Log In on the RSA login page it immediately redirects to a blank page with the path: WebID/IISWebAgentIF.dll.
 
Image descriptionImage description

 

Cause

There are several possible causes:
  • Misconfiguration of the IIS App Pool.
  • Javascript is disabled in user's web browser.
  • The Web Agent install directory has improper permissions.

Resolution

There are several points to check for fixing this issue:
  1. The WebID component of RSA Web Agent needs to have the SecurID App Pool in use by it from the IIS management interface.
 Image descriptionImage description
  1. Make sure that Javascript is enabled in the browser from which you are testing.
  2. Make sure the RSA Web Agent install directory has the proper permissions (that is, read/write by the web server named IUSR).
Image descriptionImage description

Notes

  1. After making these changes make sure to restart the browser and clear browser cookies.
  2. And most importantly restart the IIS service by opening PowerShell or a command line window and typing:
iisreset
Tags (51)
  • 7
  • 7.0
  • 7.0.x
  • 7.x
  • 8
  • 8.0
  • 8.0.x
  • 8.x
  • Agent
  • Auth
  • Auth Agent
  • Auth Issue
  • Authentication
  • Authentication Agent
  • Authentication Issue
  • Break Fix
  • Break Fix Issue
  • Broken
  • Can't Log In
  • Can't Login
  • Cannot Log In
  • Customer Support Article
  • Failed Login
  • Issue
  • Issues
  • KB Article
  • Knowledge Article
  • Knowledge Base
  • Login
  • Login Issue
  • Problem
  • RSA SecurID
  • RSA SecurID Access
  • RSA SecurID Suite
  • SecurID
  • SecurID Access
  • SecurID Agent
  • SecurID Suite
  • Unable to log In
  • Version 7
  • Version 7.0
  • Version 7.0.x
  • Version 7.x
  • Version 8
  • Version 8.0
  • Version 8.0.x
  • Version 8.x
  • Web
  • Web Agent
  • Web Authentication Agent
  • Web Server
0 Likes
Was this article helpful? Yes No
Share
No ratings

In this article

Version history
Last update:
‎2020-12-12 04:55 PM
Updated by:
Administrator RSA-KB-Sync Administrator

Related Content

Powered by Khoros
  • Blog
  • Events
  • Discussions
  • Idea Exchange
  • Knowledge Base
  • Case Portal
  • Community Support
  • Product Life Cycle
  • Support Information
  • Customer Success
  • About the Community
  • Terms & Conditions
  • Privacy Statement
  • Provide Feedback
  • Employee Login
© 2022 RSA Security LLC or its affiliates. All rights reserved.