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RSA Authentication Manager 8.x: Large Disk Space Used by Logs

Article Number

000036019

Applies To

RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
 

Issue

A large number of very old data in the database causes high disk space utilization, as well as replication issues due to slow response from the database. 

Cause

The reason the automatic archive job does not purge this data periodically is that those archive log files are being created under /opt/rsa/am/server and not under /opt/rsa/am/Log_archive as required.
This is due to migration from 7.1, the database has the location for the archive log incorrectly set as /opt/am/server/server. 

Resolution

Fix is released in AM 8.2 SP1 P7
Unless the Archive now or schedule archive page is modified with different parameters and saved, the database value doesn't get updated for the log location. 

Workaround

Update the Security Console > Administration > Archive Audit Logs > Archive now or Schedule Log Archive or both, by changing the number of days to something different from that is already present and save:
Image descriptionImage description
 

Notes

This needs to be done one time, this will update the log archival location to the proper one: /opt/rsa/am/Log_archive

Once the archive job runs successfully, check the location /opt/rsa/am/Log_archive location for the new files. 
After this, the automated jobs should purge the data periodically as expected.
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Last update:
‎2020-12-12 09:45 PM
Updated by:
Administrator RSA-KB-Sync Administrator

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