AM 8.1: Cannot add or manage a user with user ID <UserID>. User IDs must be unique within a deployment. This user ID is already in use.
2 months ago
Originally Published: 2016-03-21
Article Number
000064552
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.1.0
Platform: VMware
Platform (Other): null
O/S Version: null
Product Name: RSA-0010810
Product Description: RSA-0010810
Issue
-Getting this error when trying to perform an administrative task on a certain user ( assigning token, adding to a group, etc )
"Cannot add or manage a user with user ID <UserID>. User IDs must be unique within a deployment. This user ID is already in use."
Cause
There could be a few potential causes:

1-There are actually multiple entries for the same user in different identity sources.
2- Issue with an unresolvable user in the LDAP.
3-This is intended, i.e: customer needs to have duplicate users in the environment.
Resolution
For the 1st Cause:
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Run a search for the specific User ID across all identity sources:
1.Go to the Security Console> Identity tab > Users > Manage existing
2.Under Search Criteria, click on Search for users across all identity sources, enter User ID and run the search.
3.If you get multiple results for the same user, delete all of them except for the required user entry.

For the 2nd Cause:
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The solution can be found in this KB article: 000011632.                                   

For the 3rd Cause:
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The solution can be found in this KB article: 000017718.