Data Purging does not complete in the configured time limit in RSA Identity Governance & Lifecycle
4 years ago
Originally Published: 2021-08-03
Article Number
000044275
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.1.0, 7.1.1, 7.2.0, 7.2.1
Issue

RSA Identity Governance & Lifecycle Data Purging does not complete in the configured (default 4 hours) time period.

The Details for Run for the Data Purging task shows that Data Purging is stuck "in Progress" in "Step 2/10: Purging Access Request Details".  The Database logs for run show that the Data Purging is still executing the task "Starting Cleanup of Wp Wi alerts".

The following SQL Id for the problem queries may show up in the AWR Report:

buvu3puh8d8cd
0wtwjdf9yquzr
Cause

This is a known issue in the following versions where long-running individual queries in the WorkPoint cleanup may cause Data Purging not to respect the configured (default 4 hours) timeout:

  • RSA Identity Governance & Lifecycle 7.1.0
  • RSA Identity Governance & Lifecycle 7.1.1
  • RSA Identity Governance & Lifecycle 7.2.0
Resolution
This issue is resolved in the following versions.  These versions now limit the WorkPoint purge to a percentage of the configured (default 4 hour) limit.  These versions also include performance improvements for the WorkPoint Alert purge step.
  • RSA Identity Governance & Lifecycle 7.1.0 P09
  • RSA Identity Governance & Lifecycle 7.1.1 P08
  • RSA Identity Governance & Lifecycle 7.2.0 P02
  • RSA Identity Governance & Lifecycle 7.2.1
  • RSA Identity Governance & Lifecycle 7.5.0