Entitlement Views show zero items in RSA Identity Governance & Lifecycle after installing a 7.1.x patch
2 years ago
Originally Published: 2019-07-11
Article Number
000040927
Applies To
RSA Product Set: Identity Governance & Lifecycle
RSA Version/Condition: 7.1.0, 7.1.1

 
Issue
After upgrading RSA Identity Governance & Lifecycle 7.1.1 GA to 7.1.1 P01/P02 or upgrading to a patched version of 7.0.2, all entitlement views that previously displayed entitlements now show zero entitlements (items). 

 
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The following error can be seen in the aveksaServer.log:
 
07/11/2019 15:31:04.494 WARN  (default task-4) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] 
SQL Error: 904, SQLState: 42000
07/11/2019 15:31:04.496 ERROR (default task-4) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] 
ORA-00904: "APP"."TECHNICAL_OWNER_NAME": invalid identifier

Please refer to article 000030327 - Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the log files for your specific deployment.
 
Cause
This issue occurs when there is a custom attribute defined for a Group or Application Role or Role and if the Attribute Name is Technical Owner, Business Owner, or Exception Manager. This is a known issue reported in ACM-98888. 

In the example below, note the user Attribute Name Technical Owner defined as an Application Role attribute:
 
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Resolution
This issue is resolved in the following RSA Identity Governance & Lifecycle patches:
  • RSA Identity Governance & Lifecycle 7.1.0 P09
  • RSA Identity Governance & Lifecycle 7.1.1 P03
Workaround
A workaround is to rename all occurrences of the attribute names wherever they are defined (group, application role, role):
  • Change Technical Owner to Technical Owner Name
  • Change Business Owner to Business Owner Name
  • Change Exception Manager to Exception Manager Name
     
In the following example, the Attribute Name Technical Owner is changed to Technical Owner Name.

In the RSA Identity Governance & Lifecycle user interface,
  1. Go to Admin > Attributes > [Edit the Attribute Name Technical Owner and modify to Technical Owner Name ] > Click OK.
  2. You will get a Java exception error that may be safely ignored. To bypass the error, cancel out of the attribute editor and the change will be saved.
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  1. Now the entitlement view shows the expected list of entitlements (items):
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NOTE: You will not be able to filter on Technical Owner Name in certain scenarios. For example, the following screenshot is from a User Access Rule Definition. The error is similar to the Java exception error mentioned above, but this change cannot be saved.
 
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