Error message "Our process does not support use of public accounts" when registering for an RSA Community or myRSA account
a year ago
Originally Published: 2017-11-29
Article Number
000040610
Applies To
This article applies to new users who are registering for an RSA Community and/or myRSA account.
Issue
When attempting to register for an RSA Community and/or myRSA account, the error message below is displayed after entering my email address.
Our process does not support use of public accounts. Please enter a valid Email ID and Try again.
User-added image
Cause
This error occurs because you attempted to register for an RSA Community and/or myRSA account using a free email service such as Gmail, Yahoo, MSN, or other online services.
Resolution
You must use your corporate email address (i.e. your business email used at your company) when registering for an RSA Community and/or myRSA account.
 
If you believe that you are seeing this message in error and that your email domain should be accepted, please contact RSA Customer Support and reference this article for further assistance.
Notes
For more information on registering for an RSA Community account, please refer to the registration tutorial.
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