RSA Identity Router's setup.jsp Network Diagnostics page displays HTTP error 503 or "Service Temporarily Unavailable" or "Service Unavailable"
2 years ago
Originally Published: 2018-09-24
Article Number
000041114
Applies To
RSA Product Set: SecurID Access
RSA Product/Service Type: Identity Router
RSA Version/Condition: all
Issue
The RSA Identity Router (IDR) Network Diagnostics page is part of the IDR's setup.jsp console, as described in the online help page View Network Diagnostics on an Identity Router.
When the RSA Identity Router is busy, it may not be able to display Network Diagnostics information within a reasonable period of time, so it will return an HTTP error code 503 to the web browser.  Depending on the type of web browser that is being used, one or more of the following will be displayed:
  • Error 503
  • Service Unavailable
  • Service Temporarily Unavailable
  • The server is temporarily unable to service your request due to maintenance downtime or capacity problems.  Please try again later.
The web browser continues to show the same error every time the web page is refreshed.  This is because using Refresh in the web browser is a soft refresh.  It just reloads the current page from the web browser's local cache, which usually will just re-display the same error message that the browser displayed previously.

HTTP error 503 is defined in the HTTP/1.1 Semantics and Content standard and is the normal response sent from a server to a web browser when the server is busy.
Cause
This issue is known to occur sometimes when the Identity Router cannot connect to the Cloud.  The Identity Router status will be Distressed in the Cloud Administration Console.
 
Workaround
Use hard refresh in the web browser to force the browser to fetch the page again from the IDR (rather than just reloading the page from the web browser's local cache).  If the IDR is not still busy at that point, the page should load correctly.
If hard refresh does not immediately display the Network Diagnostics page, retry it a few times, waiting at least 30 seconds between each retry.
Hard refresh means doing one of the following:
  • holding down the CTRL key on your keyboard, while simultaneously clicking the browser's refresh icon.  The refresh icon is usually a circular arrow, such as:  Chrome refresh icon, or
  • simultaneously pressing the CTRL and F5 keys on your keyboard, or
  • simultaneously pressing the CTRL, shift and R keys on your keyboard.
Check your browser's documentation or online help if in doubt about the correct way to use hard refresh.
If the Network Diagnostics page is continuously unavailable, even after retrying hard refresh over a period of time, first try to fix the connectivity between the IDR and the Cloud, as that should also resolve Network Diagnostics page issue.  Follow these steps if additional help is needed:
  1. Contact RSA Customer Support.
  2. Generate and download the Identity Router's log bundle from the IDR's setup.jsp console (not from the Cloud Administration Console)
  3. Upload the Identity Router's log bundle to RSA Customer Support for analysis