System internal error on RSA Authentication Manager 8.x when accessing options under System Settings for Email (SMTP), Logging, Session Handling, Caching and/or Network Monitoring (SNMP)
5 months ago
Originally Published: 2025-10-21
Article Number
000073666
Applies To

Authentication Manager 8.x

Issue
  1. On the Security Console, navigate to Setup > System Settings.
  2. Select one of the options below that are highlighted in red (Email (SMTP), Logging, Session Handling, Caching and/or Network Monitoring (SNMP)):

The error below displays: 

System Internal Error
There was a problem processing your request. Contact your system administrator.

 

Cause

A replica has failed to attach or has become out of sync with the primary.  All of the options highlights above will bring up an option to choose instance to which the changes should apply.  Since one instance is offline, the system cannot select it and throws the error.

 

For some reason the replica either never attached to the primary, or has become severely out of sync.  On the Operations Console, check Replication Status. The replica was showing <unknown>  both for  name and for date of last replication.

Resolution

To resolve the error, 

  1. Login to the Operations Console on the primary server.
  2. Navigate to Deployment Configuration > Instances.
  3. Delete the faulty replica.
  4. Generate a new replica package.
  5. Follow steps in the Authentication Manager Setup and Configuration Guide for your version of Authentication Manager to stand up a new virtual server to attach it to the primary as a replacement replica. 
Notes

Removing this replica from the deployment via the Operations Console immediately resolved the issue.