The License/serial number being installed does not match the license/serial number stored on the server when installing an RSA Authentication Manager license
2 months ago
Originally Published: 2008-08-20
Article Number
000046582
Applies To
RSA Product Set:  SecurID
RSA Product/Service Type:  Authentication Manager
RSA Version/Condition:  8.x

 

Issue
When replacing an Authentication Manager trial license with a production license/a refresh license the customer serial will change, causing an error.  
Cause

When replacing an Authentication Manager trial license with a production license/a refresh license, a check is done comparing the current serial number to the new one.  If the numbers do not match the following error will display:  
 

Error installing license: The License/serial number being installed does not match the license/serial number stored on the server.
Error installing license: The License/serial number being installed does not match the license/serial number stored on the server. 
Resolution
Before applying the new license,
  1. Login to the Authentication Manager primary server's Security Console as a super admin user.
  2. Go to Setup > License > Status and click on View Installed Licenses
  3. Click the context arrow next to the License ID number and choose View
  4. Compare the license serial number visible in the Security Console to the license number in the license .xml file you received, specifically the license:customerAccountId value.
If the license numbers are the same, the new license can be installed immediately.  Licenses for Authentication Manager are stackable, and the new license will be added on top of the existing license.

If the license numbers are the same

If the license numbers are the same, the new license can be installed immediately.  Licenses for Authentication Manager are stackable, and the new license will be added on top of the existing license.
  1. Go back to the Security Console and select Setup > License > Add New.  
  2. Browse to the folder containing the new license.xml file and select it.
  3. Click Next then verify the information regarding your license is correct.
  4. Click the Install button.
If the license numbers are different, first uninstall the old license then install the new one.  Failure to do this will cause the following error to display: 

The License/serial number being installed does not match the license/serial number stored on the server.

If the license numbers are different

CAUTION: Do not restart the server or reboot the Authentication Manager services until you complete steps 1 through 7 below.  Install the new license right away. 

  1. From the Security Console select Setup > License > Status, then click View Installed Licenses.
  2. Click the context arrow next to the license ID and choose Uninstall.
  3. Check the Yes, Uninstall License box.
  4. Click the Uninstall License button.  

At this point, do not restart the Authentication Manager server.  Install the new license right away.  Do not reboot the server or restart Authentication Manager services until you complete the next steps.  Rebooting the server or restarting the Authentication Manager services while there is not a license installed can cause irreparable harm to the server which will prevent the software from starting and may require a factory reset. 

  1. Go back to Setup > License > Add New.  Browse to the folder containing the new license.xml file and select it.
  2. Click Next then verify the information regarding the license is correct.
  3. Click the Install button. 
 

 

Notes
  • The license install process should be complete in less than five minutes.
  • The license is installed only on the Authentication Manager primary server. 
  • License changes are pushed out from the primary to the replicas in the deployment by a batch job that runs daily.
  • Once the license install process is complete on the Authentication Manager primary, it is immediately applied.
  • RSA services do not need to be restarted, and the server does not need to be rebooted after the license is installed for the new license to take effect.
  • If adding a new stack to the existing license, there will be no downtime with regard to authentication.
  • If a previous license needs to be removed, any users who are already authenticated will not have their sessions dropped.
  • Between the time that the old license is uninstalled and the new license is installed any users that try to authenticate may get an error.  Since the license install process is so quick, very few users are affected by this.
  • If you have a trial license installed and need to extend your trial period, contact RSA for a new trial before the old license expires.
  • Install the new trial license before the old one expires.