Websphere installation fails to start with java.lang.NullPointerException in RSA Identity Governance & Lifecycle
Originally Published: 2018-10-29
Article Number
Applies To
RSA Version/Condition: 7.x
Platform/Application Server : WebSphere 8.5.5
Issue
java.lang.NullPointerException error
The aveksaServer.log file has the following corresponding error:
"10/04/2018 17:52:32.628 ERROR (server.startup : 0) [com.aveksa.init.Startup]
Error logging audit event on startup java.lang.NullPointerException
at com.aveksa.server.db.persistence.PersistenceServiceProvider.createSession(PersistenceServiceProvider.java:476)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.currentSession(PersistenceServiceProvider.java:439)
at com.aveksa.server.db.persistence.PersistenceServiceProvider.find(PersistenceServiceProvider.java:984)"
Note: The aveksaServer.log file on WebSphere may be found in a directory similar to the following (where the specific node name would be different): /home/oracle/IBM/WebSphere/AppServer/profiles/AppSrv01/installedApps/vm-support-11Node01Cell/aveksa.ear/aveksa.war/log.
Cause
Resolution
To configure the shared library:
- From the WebSphere admin console, go to Environment > Shared libraries.
- Set the scope for your configuration:
- (Standalone) Node=<machine-name>Node01, server=server1
- (Cluster) cells=MyCluster
- Click New to create the shared library:
- Name: Aveksa Shared Library
- Classpath: Full path to hibernate-jpa-2.0-api-1.0.1.Final.jar and javassist-3.18.1-GA.jar that are included in the DISTRIBUTION directory.
- /opt/ACM-WebSphere-<product version>/hibernate-jpa-2.0-api-1.0.1.Final.jar, and
- /opt/ACM-WebSphere-<product version>/javassist-3.18.1-GA.jar
- Under the Class Loading section, select Use an isolated class loader for this shared library.
To associate the Aveksa Shared Library with the Aveksa EAR:
- From the WebSphere admin console, go to Applications > Application Types > WebSphere enterprise applications.
- Select the aveksa application on the Enterprise Applications page.
- Under the References section, click the Shared library references link.
- Select the aveksa application, and then click Reference shared libraries.
- On the Shared Library Mapping page, select Aveksa Shared Library from the Available list and move it to the Selected list.
- Click OK to save changes.
Related Articles
SecurID Governance & Lifecycle 7.5.2 Patch 11 Release Notes 14Number of Views RSA Via Lifecycle and Governance/Aveksa server will not start after environment customization 227Number of Views Cannot login with AveksaAdmin password after importing a database from another environment into RSA Identity Governance an… 215Number of Views RSA Authentication Agent 8.0 for Web for IIS 7.5 8.0 8.5 8.6 and 10 Installation and Configuration Guide 303Number of Views Deployment of the aveksa.ear in a clustered environment fails with 305000 ms timeout error in RSA Identity Governance & Li… 228Number of Views
Trending Articles
Download RSA SecurID Access Cloud User Event audit logs using Cloud Administration REST API CLU RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update Authentication Manager How to Retrieve the LDAPS Certificate and Configure an External Identity Source to Use LDAPS
Don't see what you're looking for?