FSM getting error 'SSL handshake failure'
Originally Published: 2008-09-24
Last Modified: 2023-09-22
Article Number
000060823
Applies To
RSA File Security Manager 2.2.1
Red Hat Linux Advanced Server 3.X
Issue
FSM getting error "SSL handshake failure"
Unable to connect to their database anymore - changed password policy for users and got error "handshake fail - SSL handshake failure - error in doing a handshake to server on port 5765 missed a heartbeat. "
Resolution

The FSM Adapter Service was not running on the Adapter

Here is command to start:

$> RSASecureFSService [status|start|stop|restart|installpath|rmmodule]

Status: Provides the status of the Adapter service whether running or stopped.
Start: Starts the Adapter service.
Stop: Stops the Adapter service.
Restart: Restarts the Adapter service.
Installpath: Displays the path at which the Adapter package is installed.
Rmmodule: Tries to remove the kernel modules associated with the Adapter.