Menu bar goes missing in the RSA Identity Governance & Lifecycle user interface when switching URLs
2 years ago
Originally Published: 2019-07-22
Article Number
000040987
Applies To
RSA Product Set: Identity Governance & Lifecycle
RSA Version/Condition: All

 
Issue
The menu bar and all associated menus in RSA Identity Governance & Lifecycle disappear when switching to a different URL as seen in the example below:


 

The menu bar is present in this screenshot:

User-added image

After switching URLs, the menu bar is missing as shown in the following screenshot:

User-added image
Cause
This problem occurs when a URL is redirected to an intermediary server such as a load balancer or SAML/SSO authentication provider that cannot handle a URL request that is longer in length than 4000K characters.
Resolution
Contact the vendor that is processing the URL request for resolution.


 
Workaround
Connect directly to the RSA Identity Governance & Lifecycle Application Server from your browser.
 
Notes
More information may be found in section 3.1.1 of the Internet Standards Document on HTTP which says: "It is RECOMMENDED that all HTTP senders and recipients support, at a minimum, request-line lengths of 8000 octets."