RSA Authentication Manager 8.2 upgrade applied to Dell R710 hardware and reboot not completing
2 years ago
Originally Published: 2017-06-09
Article Number
000065066
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.2
 
Issue
Upgrade to Authentication Manager  8.2 on certain Dell R710 hardware appliances result is the boot time exceeding 30 to 40 minutes

The /var/log/messages file may have a significant gap in time as the gap from 13:07:49 to 13:37:51 as shown below.  Why are the code snippets from a 3.0 server in  our lab and not from  an 8.2 machine?

Jul 20 13:07:49 cs-appliance3-02 ntpd[8625]: switching logging to file /var/log/ntp
Jul 20 13:07:49 cs-appliance3-02 /usr/sbin/cron[8637]: (CRON) STARTUP (V5.0)
Jul 20 13:37:51 cs-appliance3-02 – MARK –
Jul 20 13:37:51 cs-appliance3-02 sudo: rsaadmin : TTY=unknown ; PWD=/opt/rsa/am/server ; USER=root ; COMMAND=/opt/rsa/am/utils/bin/appliance/queryTimeSettings.sh

Additionally after booting completes, the kernel log (dmesg) will be flooded with messages similar to the following:
pci 0000:01:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
 
 
Cause
This is an issue in SUSE Linux Enterprise Server 11.  Citation?
Resolution
  1. Allow the server time to reboot, which has been seen as long as 60 minutes.
  2. Download RSA Authentication Manager 8.2 SP1 from RSA Authentication Manager 8.2 SP1 Downloads
  3. Apply the service pack following the steps in the readme.