RSA Identity Governance and Lifecycle invalid credentials for default email account error in when using valid username and password
2 years ago
Originally Published: 2017-07-06
Article Number
000063664
Applies To
RSA Product Set: RSA Identity Governance and Lifecycle

 
Issue
When setting up a Default Email Account (Admin > Email > Settings) and checking Yes to Authentication then entering a valid username and password, the test of the email fails with the following error:

Invalid credentials for default email account
      User-added image

The Settings configuration looks similar to this:
 
User-added image


The aveksaServer.log shows the following error:
06/20/2017 09:10:02.654 INFO  (default task-2) [com.aveksa.server.email.EmailClient] Connecting to Mail Server/Sending Message took 0 seconds
06/20/2017 09:10:02.655 WARN  (default task-2) [com.aveksa.server.email.EmailSenderServiceClient] Authentication Exception connecting to the default mail server with the default account.
javax.mail.AuthenticationFailedException: No authentication mechanisms supported by both server and client
        at com.sun.mail.smtp.SMTPTransport.authenticate(SMTPTransport.java:769)
        at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:687)
        at javax.mail.Service.connect(Service.java:345)


 
Cause
The SMTP email server does not support authentication.
Resolution
From Admin > Email > Settings set authentication to No in the configuration settings and optionally require SSL:
 
User-added image