Replica not listed in Primary Console
3 years ago
Originally Published: 2012-11-22
Article Number
000050708
Issue
Attach Replica to Primary

On Primary: Replica not listed in Operations and Security Consoles of Primary

On replica: Primary listed in Security Console of Replica. Status "Not running". Operations console "Unable to retrieve replication information"


rsautil setup-replication -a set-primary fails with error " Error: Setting up queue at [name of oracle DB]"

Cause
After a replication failure, Replica was attached to Primary without performing a clean-up

Database corruption

Resolution
Verify if Replica is listed in Primary "rsautil setup-replication -a list"

If no replica listed, proceed with cleanup. Do not run set Primary and remove primary commands if there are any working replicas in the deployment

rsautil setup-replication -a remove-primary

rsautil manage-rep-error -a run-script -o cleanup_propagation.sql

rsautil setup-replication -a set-primary
Once this successfully completes, continue with steps mentioned in a51069

If set Primary fails, follow 
a55272 and then continue with
a51069
Notes
Make sure to have a backup done before proceeding with any of the above steps