Log Artifact zip file fails to generate in RSA Governance & Lifecycle
3 years ago
Article Number
000068050
Applies To
  • SecurID Governance & Lifecycle 7.5.2
  • RSA Identity Governance & Lifecycle 7.5.0
  • RSA Identity Governance & Lifecycle 7.2.x
Issue
Log artifact generation fails with the following error on the UI > Admin > Diagnostics > Log Artifact:
User-added image

The following error is being logged in the aveksaServer.log:
05/30/2022 09:53:09.232 ERROR (LogArtifactJob) [com.aveksa.gui.pages.admin.downloadLogs.LogArtifactJob] Error while executing log artifact job, java.io.IOException: No such file or directory

The log artifact generation log stop at Telemetry Logs, as seen in the log file  /home/oracle/CollectedLogs/LogArtifactSummary.log:
Informational messages reported during this run: 
Gathering ACM Logs (Start: 8/1/22 10:33 AM)
Gathering ACM Logs (Stop: 8/1/22 10:33 AM)
Gathering Aveksa Server Logs (Start: 8/1/22 10:33 AM)
Gathering Aveksa Server Logs (Stop: 8/1/22 10:33 AM)
Gathering AFX Logs (Start: 8/1/22 10:33 AM)
Gathering AFX Logs (Stop: 8/1/22 10:33 AM)
Gathering Migration Logs (Start: 8/1/22 10:33 AM)
Gathering Migration Logs (Stop: 8/1/22 10:33 AM)
Gathering Patch Logs (Start: 8/1/22 10:33 AM)
Gathering Patch Logs (Stop: 8/1/22 10:33 AM)
Gathering Oracle Logs (Start: 8/1/22 10:33 AM)
Gathering Oracle Logs (Stop: 8/1/22 10:33 AM)
Gathering ASR Report (Start: 8/1/22 10:33 AM)
Gathering ASR Report (Stop: 8/1/22 10:34 AM)
Gathering Telemetry Logs (Start: 8/1/22 10:34 AM)
Cause
Customer Name value contains a slash ( "/" ) which is being interpreted as a directory when generating the log artifact.

 
Resolution
This issue is resolved in the following version/patch:
  • SecurID Governance & Lifecycle 7.5.2 P06
Workaround
Edit the Customer Name and remove the forward slash "/":
  1. Go to the UI > Admin > System > Settings, Click Edit
  2. Scroll to the Environment section, and edit Customer Name value to remove the forward slash "/"
User-added image
  1. Click OK to save the change